We are currently seeing delays in processing Remittance, Payouts, Disbursements to the following PHP destinations due to system issues with our partner.
PH_UBP: above 50001 Other banks and Ewallets: 1-50000
Posted Feb 24, 2025 - 01:00 WIB
Update
Dear valued customers,
We are currently seeing delays in processing Remittance, Payouts, Disbursements to the following PHP destinations due to system issues with our partner.
PH_GCASH: 1-50000 PH_UBP: All amount Other banks and Ewallets: 1-50000
Posted Feb 24, 2025 - 00:50 WIB
Identified
Dear valued customers,
We are currently seeing delays in processing Payouts, Disbursements to the following PHP destinations due to system issues with our partner.
PH_UBP: All amount Other banks and Ewallets: 1-50000
Posted Feb 24, 2025 - 00:40 WIB
This incident affected: Philippines - Payouts (Disbursement - Other Philippines banks and E-Wallets).