CREDIT_CARDS Disruption
Incident Report for Xendit
Resolved
Dear Customers,

This incident has been resolved.

Sincerely,
Xendit customer service
Posted Mar 28, 2024 - 01:20 WIB
Identified
Dear Valued Customers,

We have detected a disruption in CREDIT_CARDS payments due to disruption on our partner.

Impact:
Payment option (installment and point retrieval) can't be performed.

We are inquiring about more information from our partner and will keep this page updated as we hear news from our partner.

Sorry for the inconvenience caused.

Sincerely,
Xendit customer service
Posted Mar 28, 2024 - 01:10 WIB
This incident affected: Credit/Debit Cards (Credit Card - BCA_PG).