Short Form Payment Link URL for Invoices Not Available
Incident Report for Xendit
Resolved
All notifications that relied on the shortend form of the payment link URL have now been re-sent. The service is operating normally.
Posted Dec 07, 2023 - 22:56 WIB
Update
For any impacted transactions that were missing the shortened form of the payment URL, we have completed recovery. All transactions now have a shortened and long form URL available to merchants in the Xendit application.

Notifications sent previously that relied on the shortened form of the URL (e.g. SMS notifications) have not yet been resent with the payment link. We recommend:
1. For urgent, unpaid invoices created after 4:20AM WIB today that used SMS as a notification method, you may elect to contact those customers directly with the payment links available in the Xendit application for immediate payment.
2. For invoices created after 4:20AM that used SMS as a notification method, we will automatically resend the notification with the payment link in the next 24 hours.

We will update and resolve this incident as soon as the notifications are resent.
Posted Dec 07, 2023 - 17:14 WIB
Monitoring
Starting at 4:20am WIB, the short-form payment link URLs for invoices were not available in Xendit applications. The longer form of the URL was available and is functioning normally.

The issue has been fixed and both short and long payment link URLs are available in the Xendit application.

For any impacted transactions missing the shortened URL, we are currently running a procedure to create the correct short URL and update the record.

We will update the incident when the procedure completes and all transactions have both a short and long-form URL.
Posted Dec 07, 2023 - 13:16 WIB
This incident affected: Dashboard (Payment Links).