GCash Billpay Maintenance
Incident Report for Xendit
Resolved
We've confirmed with the parter that this emergency maintenance is concluded. We apologize for the inconvience.
Posted Mar 27, 2024 - 21:26 WIB
Investigating
Dear Merchants,

Gcash Bill Payment is currently under emergency maintenance. We are working to restore service with the partner as quickly as possible. We will keep you updated on our progress. In the meantime, please consider using alternative channels such as Paymaya to pay. Please reach out to our customer success team if you need support in redirecting payments to alternative channels.
Posted Mar 27, 2024 - 16:19 WIB
This incident affected: Philippines - Payments (Over-The-Counter Payments - GCash Billpay).