Disbursements to BCA Delays
Incident Report for Xendit
Resolved
This incident has been resolved.
Posted Oct 08, 2024 - 19:49 WIB
Update
We are monitoring impacted disbursements at 5% currently. We shall keep this status posted on further updates from our partners
Posted Oct 08, 2024 - 19:02 WIB
Update
We are looking at 1-2% of disbursements to BCA impacted by processing delays on the partner side
Posted Oct 08, 2024 - 18:54 WIB
Monitoring
We are monitoring issues with BCA as a destination account. We are closely working with our partners for updates
Posted Oct 08, 2024 - 18:49 WIB
This incident affected: Indonesia - Payouts (Disbursement - BCA).