Direct Debit BPI Recurring Disruption

Incident Report for Xendit

Resolved

This incident has been resolved.
Posted Jun 22, 2026 - 22:00 WIB

Identified

Dear Customers,

We have identified an issue with the BPI Recurring channel with making payments.

Customers will see a 500 response when trying to create payments using this channel.

We have escalated to our partner and will keep you informed of any updates.


Best Regards,
Xendit Team
Posted Jun 22, 2026 - 16:19 WIB
This incident affected: Philippines - Payments (Direct Debit - BPI Recurring).