Over-The-Counter ECPAY_LOAN Philippines Disruption
Incident Report for Xendit
Resolved
Dear Customers,

This incident has been resolved.

Sincerely,
Xendit customer service
Posted Jul 19, 2024 - 20:31 WIB
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 19, 2024 - 20:04 WIB
This incident affected: Philippines - Payments (Over-The-Counter Payments - ECPay Loans).