BCA VA Maintenance
Incident Report for Xendit
Resolved
This incident has been resolved.
Posted Feb 04, 2024 - 07:18 WIB
Investigating
Dear Customers,

We just received information that they are undergoing maintenance on Feb 4 01:00 - 04:00 WIB
Posted Feb 04, 2024 - 03:22 WIB
This incident affected: Indonesia - Payments (Virtual Account - BCA).