Intermittent Dashboard Outage

Incident Report for Xendit

Resolved

Dear Customers,

We have rectified the earlier issue. The dashboard should be fully operational.

Warm regards,

Xendit Customer Support
Posted May 06, 2026 - 18:49 WIB

Identified

Dear Customers,

We are investigating an issue that may cause some users to experience intermittent failures when accessing https://dashboard.xendit.co. We are working to find a resolution as soon as possible.

Warm regards,

Xendit Customer Support
Posted May 06, 2026 - 17:55 WIB
This incident affected: Dashboard (Dashboard, Dashboard Withdrawals, Onboarding, Autowithdrawal, Batch Disbursements, Payment Links, Banking as a Service, Topup).