Card Payment 3D-Secure Disruption

Incident Report for Xendit

Resolved

This incident has been resolved.
Posted Aug 28, 2025 - 17:48 WIB

Investigating

Dear Valued Merchants,

We have confirmed that there has been an on-going issue with our bank partner which are causing card payments to timeout on 3DS.

Start Time : 3:00 P.M. (GMT+7)

Impact during this incident :
- Card payments will receive timeout error on 3DS step and transaction will fail

We are closely following up with our bank partner on this issue

We will provide an update here as soon as possible and we sincerely apologize for the inconvenience caused.

Best regards,
Xendit Customer Service Team
Posted Aug 28, 2025 - 16:10 WIB
This incident affected: Thailand - Payments (Credit/Debit Cards).