Payments API Disruption

Incident Report for Xendit

Postmortem

Payment Request ID Changes in Payments API Response

Incident Date: 2023-11-22

Affected Products: E-Wallet and Direct Debit channels on Payments API

Report URL: https://status.xendit.co/incidents/7xx8gng9q2v8 

What happened? 

On 22 November 2023, our team released a change that altered the format of the primary ID in the Payment Request response. The new format is applicable to Direct Debit and E-Wallet channels.

The change was intended to be rolled out only to merchants currently not using these channels on Payments API. However, due to an incorrect data source being used to determine the list of merchants to roll this change out to, this change was unintentionally rolled out to some merchants who are currently using E-Wallet and Direct Debit channels on Payments API.

On 30 November 2023, this change was reversed for the affected merchants.

What measures are we taking to prevent this issue in future?

We are committed to building reliable services for you. To prevent similar issues in the future, we are:

  • Stopping all potentially breaking changes from being applied through whitelists. New major changes will be released in new versions of our Payments API.

We understand that you are counting on our reliability for the smooth operation of your business. We sincerely regret any inconvenience this may have caused you and your customers. We are committed to do better by applying our learnings from this event to continuously improve our services to serve you better.

If you require any assistance or have further questions, please contact us at help@xendit.co or through live chat at https://xendit.co.

Thank you for your trust in using Xendit to power your business.

Posted Dec 01, 2023 - 19:00 WIB

Resolved

Dear Valued Customers,

We have identified that there were disruptions with Payments API within below time range :

Start: 22th Nov 11:59 AM GMT+8
End : 30th Nov 10:00 AM GMT+8

Impacts are:
Changes in the unique id format we used in payment request response that might cause disruption in other post successful payments operations (refunds, dispatch, etc)

We have reverted this changes and will reach out to you to identify potential issues that might happen.
We apologize for any inconvenience it has caused.

Sincerely,
Xendit Customer Support
Posted Nov 22, 2023 - 11:00 WIB